注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

独木人生

感悟生命

 
 
 

日志

 
 

etch下安装fluent6.1.22  

2007-03-21 20:19:58|  分类: Linux |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
一时冲动,下载了Unix版的fluent进行安装。

原来已经装了gambit,运行也挺顺利,就是字体太大。

运行fluent6.1.22的安装程序后,选择gambit安装的目录。原先在windows下也是安装在一起。

Installation directory for Fluent.Inc/: /mnt/hdc5/download/fluent/

Cleaning up old links


Products included on this CD are:

        fluent6.1.22

Products to install [all]

Platforms included on this CD are:

        lnx86
        ultra

Platforms to install [all]

The following packages:

        bin
        lib
        fluent6.1.22
        utility/fe2ram4.3
        utility/fl42seg1.1
        utility/partition1.1
        utility/tmerge2.1
        utility/viewfac2.0
        addons/sge1.0
        addons/fiber1.1
        addons/acoustics1.1
        addons/mhd1.0

will be installed in /mnt/hdc5/download/fluent//Fluent.Inc/
for the following platforms:

        common
        lnx86
        ultra_64
        ultra

Continue with installation [yes]?

Installing packages...

        bin/common
        bin/lnx86
        bin/ultra_64
        bin/ultra
        lib/common
        lib/lnx86
        lib/ultra_64
        lib/ultra
        fluent6.1.22/common
        fluent6.1.22/lnx86
        fluent6.1.22/ultra_64
        fluent6.1.22/ultra
        utility/fe2ram4.3/common
        utility/fe2ram4.3/lnx86
        utility/fe2ram4.3/ultra_64
        utility/fe2ram4.3/ultra
        utility/fl42seg1.1/common
        utility/fl42seg1.1/lnx86
        utility/fl42seg1.1/ultra_64
        utility/fl42seg1.1/ultra
        utility/partition1.1/common
        utility/partition1.1/lnx86
        utility/partition1.1/ultra_64
        utility/partition1.1/ultra
        utility/tmerge2.1/common
        utility/tmerge2.1/lnx86
        utility/tmerge2.1/ultra_64
        utility/tmerge2.1/ultra
        utility/viewfac2.0/common
        utility/viewfac2.0/lnx86
        utility/viewfac2.0/ultra_64
        utility/viewfac2.0/ultra
        addons/sge1.0/common
        addons/sge1.0/lnx86
        addons/sge1.0/ultra_64
        addons/sge1.0/ultra
        addons/fiber1.1/common
        addons/fiber1.1/lnx86
        addons/fiber1.1/ultra_64
        addons/fiber1.1/ultra
        addons/acoustics1.1/common
        addons/acoustics1.1/lnx86
        addons/acoustics1.1/ultra_64
        addons/acoustics1.1/ultra
        addons/mhd1.0/common
        addons/mhd1.0/lnx86
        addons/mhd1.0/ultra_64
        addons/mhd1.0/ultra
Done.

        All Fluent Inc. software products require a license key.
        Please refer to the Fluent Installation Instructions for
        obtaining a license key, or contact your support engineer.


------------------------------------------------------------------------
FUTURE PLATFORM/OP SYSTEM SUPPORT--

The following table lists platform/OS level support for future releases
of FLUENT.  It does not necessarily show all platforms to be supported
in the future, but shows the ones being dropped from our current list.
If you have a need to keep any of the dropped platforms, please
contact your support engineer as soon as possible.

------------------------------------------------------------------------
Platform   Processors     Dropped OS            Supported OS
------------------------------------------------------------------------
Linux      Intel          Red Hat 7.1           Red Hat7.2+
WINDOWS    Intel          NT4.0                 2000, XP

Continue [yes]?

*****************************************************************************
                              PLEASE READ !!
*****************************************************************************

For full FLUENT6 functionality, please install:


   1)  Fluent 6 Documentation CD for Fluent 6 online Help. Online Help
       will not be accessible without this installation.


*****************************************************************************


        If a separate  documentation CD is included with
        the  product, it must be installed to access online help.
        Without documentation CD installation, you will not have
        access to online help.

安装完成,以为大功告成。等等,怎么无法运行。
Console运行fluent试试,输出错误信息:

./fluent: line 2957: unexpected EOF while looking for matching ``'
./fluent: line 3190: syntax error: unexpected end of file

只好查看fluent文件,怎么也不行。

在网上查找了一番后,修改第2280行
exec `execute_remote_command $name $PROD_DIR/multiport/$arch/$PARA_VERSION/bin/mpirun $lamnodeid $PROD_DIR/$arch/${VERSION}_node/${FP}.${VERSION_RELEASE}${EXE_POST} $NODE_FLAGS $MP_FLAGS $CX_FLAGS \"$CX_FUNCTION\""`
改为:
exec `execute_remote_command $name $PROD_DIR/multiport/$arch/$PARA_VERSION/bin/mpirun $lamnodeid $PROD_DIR/$arch/${VERSION}_node/${FP}.${VERSION_RELEASE}${EXE_POST} $NODE_FLAGS $MP_FLAGS $CX_FLAGS \"$CX_FUNCTION\"`

再试试看运行,又有错误:

/mnt/hdc5/download/fluent/Fluent.Inc/fluent6.1.22/cortex/lnx86/cortex.3.5.6 -f fluent (fluent "  -path/mnt/hdc5/download/fluent/Fluent.Inc")
/mnt/hdc5/download/fluent/Fluent.Inc/fluent6.1.22/cortex/lnx86/cortex.3.5.6: error while loading shared libraries: libstdc++-libc6.2-2.so.3: cannot open shared object file: No such file or directory

搜索后见解决方法是安装lib-compat,但debian的sources里就是没有。好歹下了一个compat-libstdc++-7.3-2.96.118.i386.rpm
结果呢
sudo rpm -ivh compat-libstdc++-7.3-2.96.118.i386.rpm
warning: compat-libstdc++-7.3-2.96.118.i386.rpm: Header V3 DSA signature: NOKEY, key ID db42a60e
error: Failed dependencies:
        /bin/sh is needed by compat-libstdc++-7.3-2.96.118.i386
        /sbin/ldconfig is needed by compat-libstdc++-7.3-2.96.118.i386
        libc.so.6 is needed by compat-libstdc++-7.3-2.96.118.i386
        libc.so.6(GLIBC_2.0) is needed by compat-libstdc++-7.3-2.96.118.i386
        libc.so.6(GLIBC_2.1) is needed by compat-libstdc++-7.3-2.96.118.i386
        libc.so.6(GLIBC_2.1.3) is needed by compat-libstdc++-7.3-2.96.118.i386
        libc.so.6(GLIBC_2.3) is needed by compat-libstdc++-7.3-2.96.118.i386
        libgcc_s.so.1 is needed by compat-libstdc++-7.3-2.96.118.i386
        libgcc_s.so.1(GLIBC_2.0) is needed by compat-libstdc++-7.3-2.96.118.i386
        libm.so.6 is needed by compat-libstdc++-7.3-2.96.118.i386
        libm.so.6(GLIBC_2.0) is needed by compat-libstdc++-7.3-2.96.118.i386

没有办法,在debian的sources里找了libg++2.8.1.3-glibc2.2libstdc++2.10-glibc2.2,安装之后
fluent工作了,OK。
  评论这张
 
阅读(471)| 评论(0)
推荐 转载

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017